読者です 読者をやめる 読者になる 読者になる

Pyclas on Security

pyclas@xmpp.cm (OTR)

IX2015 設定例

NEC製業務用VPNルーター ix2015でのconfig設定例を貼り付けておく。

面白いなと思ったのは1階と2階でPPPoE設定を使いまわしてるのだけど、プロバイダー側のradiusなんかで弾かれないこと。1つのPPP認証情報に対して、WAN側アドレスが2つ割り振られている状態になっている。

1階 (Buffalo BHR-300HR) BIGLOBE PPP profile A : 0.0.0.0 2階(NEC IX2015 ) BIGLOBE PPP profile A : 0.0.0.0

f:id:pyclas:20160417211909j:plain

ルーター周りはAPCUPSにぶら下げてる。 f:id:pyclas:20160417212024j:plain

f:id:pyclas:20160417213154j:plain tera term側で操作ログの有効化をしておくと良い。

! NEC Portable Internetwork Core Operating System Software
! IX Series IX2010 (magellan-sec) Software, Version 7.3.21, RELEASE SOFTWARE
! Compiled Nov 17-Thu-2005 11:45:52 JST #2
! Current time Apr 10-Sun-2016 15:29:33 JST
!
!コンフィグ表示時はパスワードをハッシュ化
service password-encryption
!
!ホストネームとタイムゾーンの設定
hostname router11
timezone +09 00
!
!ルーターのユーザー認証
username XXXX password hash 840402B2SS14BEC54D1C54 administrator
username XXXX password hash 84040AASDSDSA2B21X4EXC541C54 administrator
!
!NTPサーバーの設定
ntp ip enable
ntp server 133.243.238.242
ntp server 210.173.160.27
ntp retry 3
ntp interval 3600
!
!インターフェイスとDHCPの設定
ip route default FastEthernet0/0.1
ip dhcp enable
ip access-list admin_console permit ip src any dest 192.168.49.0/24
!
!proxy-dnsの有効化
proxy-dns ip enable
!
!Telnetの有効化
telnet-server ip enable
!
!PPPoE接続設定プロファイル
ppp profile flets
  authentication myname XXXXXXX@biglobe.ne.jp
  authentication secret-password 1 XXXXXXX@biglobe.ne.jp 5oqCDt106N!oOpgO8JeeEvvv
!
ip dhcp profile lan11
  assignable-range 192.168.12.65 192.168.12.99
  default-gateway 192.168.12.1
  dns-server 8.8.8.8 8.8.4.4
!IF設定
device FastEthernet0/0
!
device FastEthernet0/1
!
device FastEthernet1/0
!
device BRI1/0
  isdn switch-type hsd128k
!
interface FastEthernet0/0.0
  no ip address
  no shutdown
!
interface FastEthernet0/1.0
  ip address 192.168.49.9/24
  no shutdown
!
interface FastEthernet1/0.0
  ip address 192.168.12.1/24
  ip dhcp binding lan11
  no shutdown
!
interface BRI1/0.0
  encapsulation ppp
  no auto-connect
  no ip address
  shutdown
!
interface FastEthernet0/0.1
  encapsulation pppoe
  auto-connect
  ppp binding flets
  ip address ipcp
  ip mtu 1492
  ip napt enable
  no shutdown
!
interface Loopback0.0
  no ip address
!
interface Null0.0
  no ip address

'''

これでPPPで自宅からフレッツのようなALには常時接続できる環境は整えられると思う。